$re = '/(\?v(?:\b|(?:er(?!sion))))/m';
$str = '?ver
?v
?version';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);