using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=:[^$\n]*)(\$[^\s:;,]*)";
string input = @".dabur-india{
color: $color-brand-group-3-light !important;
.mmm{
background: $color-brand-group-2-dark;
$border-dark: rgba($base-color, 0.88);
.alert {
border: 1px solid $border-dark;
}
}
}
$black: #000 !default;
$border-radius: 0.25rem !default;
$box-shadow: 0 0.5rem 1rem rgba($black, 0.15) !default;
code {
border-radius: $border-radius;
box-shadow: $box-shadow;
}
@if $dark-theme {
$primary-color: darken($primary-color, 60%);
$accent-color: lighten($accent-color, 60%);
}
$theme-colors: (
""success"": #28a745,
""info"": #17a2b8,
""warning"": #ffc107,
);
.alert {
// Instead of $theme-color-#{warning}
background-color: map.get($theme-colors, ""warning"");
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}