using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([0-9]{4}.+?)""";
string input = @"[[""Simon Long"", ""simon@greatnessgroup.com"", ""2018-01-01T01:01"", ""test"", ""aaa""], [""test"", ""test@gmail.com"", ""2020-01-01T01:01"", ""yeah"", ""test\r\n""]]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}