package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[A-Z]{2}[A-Z]{2}\d{2}|[A-Z]{2}\d{2}\d{2})$`)
var str = `ABCD12
AB1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}