import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b-\\b";
final String string = "Adapter - BNC Male to BNC-Female, Right Angle\n"
+ "Adapter - DB9 Female to DB9-Male, Null Modem Serial Adapter\n"
+ "Adapter - RCA Female to RCA-F\n"
+ "Adapter - DC Power 2.1x5.5mm Jack to 1.7x4.7mm Plug\n"
+ "Adapter - RJ45 Female (8-Pos) to DB25-M\n"
+ "Adapter - S-Video to Composite Video Adapter\n"
+ "Adapter - N Jack to UHF-M\n"
+ "Adapter - BNC Male to BNC-F, Right Angle\n"
+ "Adapter - DB9 Female to DB25-M, Serial Comms.\n"
+ "Adapter - DB9 Female to DB9-F, Null Modem Serial Adapter\n"
+ "Adapter - RCA Female to RCA-F, 10/pkg\n"
+ "Adapter - DC Power 2.1x5.5mm Jack to Dual 2.1x5.5mm Plug\n"
+ "Adapter - SMA Female to BNC-M\n"
+ "Adapter - DB25 Female to DB25-F, Slimline Gender Changer\n"
+ "Adapter - DC Power 2.1x5.5mm Plug to 9V Battery Clip, Ctr (+)\n"
+ "Adapter - USBA Female to USBA-F, Gender Changer\n"
+ "Adapter - USBA Male to USBA-M, Gender Changer\n"
+ "Adapter - DB9 Female to DB9-F, Slimline Gender Changer\n"
+ "Adapter - BNC Female to N-Type-M\n"
+ "Adapter - MCX Male to BNC-F\n"
+ "Adapter - DB15 Male to DB15-M, HD Slimline Gender Changer\n"
+ "Adapter - DB9 Male to DB9-M, Slimline Gender Changer\n"
+ "Adapter - SMA Male to BNC-F";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}