import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?P<aux1>\\((?:[^()]++|(?&aux1))*\\))|[\\w.])++)\\s*[!=]=\\s*((?:(?&aux1)|[\\w.])+)";
final String string = "if (programWorkflowState.getTerminal(1, 2) == Boolean.TRUE) {\n\n"
+ "Want: programWorkflowState.getTerminal(1, 2) and Boolean.TRUE\n\n"
+ "boolean ignore = !_isInStatic.isEmpty() && (_isInStatic.peek() == 3) && isAnonymous;\n\n"
+ "Want: _isInStatic.peek() and 3\n\n"
+ "boolean b = (num1 * ( 2 + num2)) == value;\n\n"
+ "Want: (num1 * ( 2 + num2)) and value";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}