const regex = new RegExp('^(?P<repository>[\\w.\\-_]+((?::\\d+|)(?=/[a-z0-9._-]+/[a-z0-9._-]+))|)(?:/|)(?P<image>[a-z0-9.\\-_]+(?:/[a-z0-9.\\-_]+|))(:(?P<tag>[\\w.\\-_]{1,127})|)$', 'gmi')
const str = `alpine
alpine:latest
_/alpine
_/alpine:latest
alpine:3.7
docker.example.com/gmr/alpine:3.7
docker.example.com:5000/gmr/alpine:latest
pse/anabroker:latest`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}