#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)(?<comment>/\*.*?\*/|\-\-.*?$)"
Local $sString = "USE [master]" & @CRLF & _
"GO" & @CRLF & _
"" & @CRLF & _
"IF OBJECT_ID('dbo.sp_foreach_db') IS NOT NULL" & @CRLF & _
" DROP PROCEDURE [dbo].[sp_foreach_db] " & @CRLF & _
"GO" & @CRLF & _
"" & @CRLF & _
"CREATE PROCEDURE [dbo].[sp_foreach_db] " & @CRLF & _
"(" & @CRLF & _
" @tsql NVARCHAR(MAX) = NULL" & @CRLF & _
" ,@replacedatabasenamepattern NVARCHAR(20) = N'?'" & @CRLF & _
"" & @CRLF & _
" ,@break_on_error BIT = 1" & @CRLF & _
"" & @CRLF & _
" ,@db_name_like NVARCHAR(128) = NULL" & @CRLF & _
" ,@db_name_in NVARCHAR(4000) = NULL" & @CRLF & _
" ,@db_name_not_in NVARCHAR(4000) = NULL" & @CRLF & _
" ,@db_use_system_db BIT = 0" & @CRLF & _
" ,@db_use_temp_db BIT = 0" & @CRLF & _
"" & @CRLF & _
" ,@push_info_msg BIT = 1" & @CRLF & _
")" & @CRLF & _
"WITH EXECUTE AS CALLER " & @CRLF & _
"AS" & @CRLF & _
"/*" & @CRLF & _
"Version: 1.0.1.0" & @CRLF & _
"Developer: Paw Jershauge" & @CRLF & _
"Created: 18-03-2016 13:01:00" & @CRLF & _
"*/" & @CRLF & _
"BEGIN" & @CRLF & _
" IF @tsql IS NULL" & @CRLF & _
" RETURN 0;" & @CRLF & _
" " & @CRLF & _
" SET NOCOUNT ON;" & @CRLF & _
" DECLARE @dbtsql NVARCHAR(MAX)" & @CRLF & _
" ,@firecode NVARCHAR(MAX)" & @CRLF & _
" ,@db_name NVARCHAR(128)" & @CRLF & _
" ,@dbnames NVARCHAR(MAX) = N''" & @CRLF & _
" ,@has_replacement BIT = 0" & @CRLF & _
" ,@msg_str NVARCHAR(2044)" & @CRLF & _
"" & @CRLF & _
" SET @dbtsql = N'SELECT @dbnames += [name] + CHAR(10) FROM [master].[sys].[databases] WHERE [state] = 0'" & @CRLF & _
" SET @dbtsql += IIF(ISNULL(@db_use_temp_db, 0) = 1, N'', N' AND [database_id] <> 2')" & @CRLF & _
" SET @dbtsql += IIF(ISNULL(@db_use_system_db, 0) = 1, N'', N' AND [database_id] > 4')" & @CRLF & _
" SET @dbtsql += IIF(NULLIF(@db_name_like, N'') IS NULL, N'', N' AND [name] LIKE ''' + @db_name_like + N'''')" & @CRLF & _
" SET @dbtsql += IIF(NULLIF(@db_name_in, N'') IS NULL, N'', N' AND [name] IN (' + @db_name_in + N')')" & @CRLF & _
" SET @dbtsql += IIF(NULLIF(@db_name_not_in, N'') IS NULL, N'', N' AND [name] NOT IN (' + @db_name_not_in + N')')" & @CRLF & _
" " & @CRLF & _
" EXEC sp_executesql @dbtsql, N'@dbnames NVARCHAR(MAX) OUTPUT', @dbnames = @dbnames OUTPUT;" & @CRLF & _
"" & @CRLF & _
" SELECT @has_replacement = CAST(CHARINDEX(ISNULL(@replacedatabasenamepattern, N'?'), @tsql) AS BIT)" & @CRLF & _
" " & @CRLF & _
" DECLARE cur_db CURSOR LOCAL FORWARD_ONLY FAST_FORWARD READ_ONLY FOR SELECT [value] FROM STRING_SPLIT(@dbnames, CHAR(10)) WHERE [value] <> N'' ORDER BY [value]" & @CRLF & _
" OPEN cur_db" & @CRLF & _
" FETCH NEXT FROM cur_db INTO @db_name" & @CRLF & _
" WHILE @@FETCH_STATUS = 0 " & @CRLF & _
" BEGIN " & @CRLF & _
" BEGIN TRY" & @CRLF & _
" SELECT @firecode = N'EXEC (N''' + IIF(@has_replacement = 0,N'Use [' + @db_name + N']; ', N'') + REPLACE(REPLACE(@tsql, ISNULL(@replacedatabasenamepattern, N'?'), @db_name), N'''', N'''''') + N''')'" & @CRLF & _
" " & @CRLF & _
" IF @push_info_msg = 1" & @CRLF & _
" BEGIN" & @CRLF & _
" SET @msg_str = CONVERT(NVARCHAR(40),GETDATE(), 121) + N':Executing on ' + @db_name" & @CRLF & _
" RAISERROR (@msg_str, 0, 1) WITH NOWAIT" & @CRLF & _
" END" & @CRLF & _
" EXEC sp_executesql @firecode" & @CRLF & _
" IF @push_info_msg = 1" & @CRLF & _
" BEGIN" & @CRLF & _
" SET @msg_str = CONVERT(NVARCHAR(40),GETDATE(), 121) + N':' + @db_name + N' Done!'" & @CRLF & _
" RAISERROR (@msg_str, 0, 1) WITH NOWAIT" & @CRLF & _
" END" & @CRLF & _
" END TRY" & @CRLF & _
" BEGIN CATCH" & @CRLF & _
" SET @msg_str = 'Database ' + @db_name + ' failed with the following message:'" & @CRLF & _
" RAISERROR (@msg_str, 0, 1) WITH NOWAIT" & @CRLF & _
" SET @msg_str = ERROR_MESSAGE()" & @CRLF & _
" RAISERROR (@msg_str, 0, 1) WITH NOWAIT --Workaround of the PRINT Command that is stacked and released in reverse order, on remote servers" & @CRLF & _
"" & @CRLF & _
" IF @break_on_error = 1" & @CRLF & _
" THROW" & @CRLF & _
" END CATCH" & @CRLF & _
"" & @CRLF & _
" FETCH NEXT FROM cur_db INTO @db_name" & @CRLF & _
" END" & @CRLF & _
" CLOSE cur_db" & @CRLF & _
" DEALLOCATE cur_db" & @CRLF & _
"" & @CRLF & _
"END" & @CRLF & _
"GO" & @CRLF & _
"" & @CRLF & _
"EXEC sys.sp_MS_marksystemobject sp_foreach_db" & @CRLF & _
"GO"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")