import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{1,})\\s([0-9]{4}-[0-9]{2}-[0-9]{2})\\s([0-9]{1,2}:[0-9]{1,2})\\s(0|1)\\s(0|1)";
final String string = "123 2017-08-01 20:15 1 0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}