#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sm)^-(?:(?!^-\r?$).)*?^:86:(?!/..../)(?:(?!^-\r?$).)*"
Local $sString = "-" & @CRLF & _
":20:296535/00000010" & @CRLF & _
":21:ABNADK2AXXX" & @CRLF & _
":25:ABNADK2AXXX/DK88ABNA0496434500" & @CRLF & _
":28C:42/00002" & @CRLF & _
":60M:C230228EUR124792,65" & @CRLF & _
":61:2302280228C1750,88NTRFC1165-23-00120//656" & @CRLF & _
":86:/TRTP/SEPA OVERBOEKING/IBAN/DK47ABNA0243508514/BIC/ABNADK2A/NAME/" & @CRLF & _
"LOOP BV/REMI/AV-RUN 24022023/202301918/EREF/C1165-23-00120" & @CRLF & _
":61:2302280228C4695,98NTRF6381310605374038//656" & @CRLF & _
":86:/TRTP/SEPA OVERBOEKING/IBAN/DK14ABNA0456766324/BIC/ABNADK2A/NAME/" & @CRLF & _
"DEV BV/REMI/ID16145 DEB. 1657139 FACT. 202303668 20" & @CRLF & _
"2303685 202303689/EREF/638131060537403857-311-2" & @CRLF & _
":61:2302280228C1349,25NTRFNOTPROVIDED//658" & @CRLF & _
":86:/TRTP/SEPA OVERBOEKING/IBAN/DK46ABNA0513892443/BIC/ABNADK2A/NAME/" & @CRLF & _
"EXAMPLE COM/REMI/202303656/EREF/NOTPROVIDED" & @CRLF & _
":61:2302280228C55845,96NTRFNOTPROVIDED//658" & @CRLF & _
":86:/TRTP/SEPA OVERBOEKING/IBAN/DK35ABNA0442867689/BIC/ABNADK2A/NAME/" & @CRLF & _
"BATH COMPANY DK/REMI/INV. 202228255-8426, OUR REF 2022611" & @CRLF & _
"73-79/EREF/NOTPROVIDED" & @CRLF & _
":61:2302280228D105000,NTRFNOTPROVIDED//658" & @CRLF & _
":86:/TRTP/SEPA OVERBOEKING/IBAN/DK98INGB0657624985/BIC/INGBDK2A/NAME/" & @CRLF & _
"TEST/REMI/OVERBOEKING/EREF/NOTPROVIDED" & @CRLF & _
":62F:C230228EUR83434,72" & @CRLF & _
":64:C230228EUR83434,72" & @CRLF & _
":86:/ACSI/ABNADK2AXXX" & @CRLF & _
"-" & @CRLF & _
":20:STARTUMS TA FW" & @CRLF & _
":25:28020050/0521322890" & @CRLF & _
":28C:017/01" & @CRLF & _
":60F:C230228GBP1473111,27" & @CRLF & _
":61:2302280228D1919,29N020NONREF" & @CRLF & _
":86:206?00AUSL-ZAHLUNG?100004649?20COMPANY?21S LT" & @CRLF & _
"D?22TRN AZV2023022800746?23URSP.-BETR.1.900,00 GBP?24KURS 0,87716" & @CRLF & _
"0 EUR ZU GBP?25GEGENWERT 2.00,08 EUR?26PROVISION FIX 7" & @CRLF & _
",50 EUR?27SWIFT-/TELE-SPESEN 2,00 EUR?28FREMDE GEB. 12,50 E" & @CRLF & _
"UR?2917.02 413337?3028020050?310537246190?32HOMETESTEXAMPLE?33S " & @CRLF & _
"LTD?34003" & @CRLF & _
":61:2302280228D16988,81N020NONREF" & @CRLF & _
":86:206?00AUSL-ZAHLUNG?100004649?20BODO GU COM?21NOT A TEST?22TRN" & @CRLF & _
"AZV2023022800749?23URSP.-BETR.16.980,48 GBP?24" & @CRLF & _
"KURS 0,877160 EUR ZU GBP?25GEGENWERT 19.358,48 EUR?26PROVISIO" & @CRLF & _
"N FIX 7,50 EUR?27SWIFT-/TELE-SPESEN 2,00 EUR?2830.01 INV-278" & @CRLF & _
"0?29*LOREM*?3028020050?310537246190?32GOLL" & @CRLF & _
"?33GOL COM?34003?60INFO 0800-1234" & @CRLF & _
"*GEB-FREI*" & @CRLF & _
":61:2302280228D867,06N020NONREF" & @CRLF & _
":86:206?00AUSL-ZAHLUNG?100004649?20NOTACOMPANY?21LTD?2" & @CRLF & _
"2TRN AZV2023022800752?23URSP.-BETR.858,73 GBP?24KURS 0,877160 EUR" & @CRLF & _
" ZU GBP?25GEGENWERT 978,99 EUR?26PROVISION FIX 7,50 E" & @CRLF & _
"UR?27SWIFT-/TELE-SPESEN 2,00 EUR?2828.01 A221322?3028020050?31053" & @CRLF & _
"7246190?32KOLL?33LTD?34003" & @CRLF & _
":62F:C230228GBP1453336,11" & @CRLF & _
"-"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)