use strict;
my $str = '{item1}, {item2} (2), {item3} (4), {item4}
(1), {item5},{item6}(5)';
my $regex = qr/\{(.[^,\n\]]*)\}\s*[\((.\d)\)]*/p;
my $subst = '{\\"name\\":\\"${1}\\", \\"count\\":\\"\\"}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";