$re = '/\|\|(?!\([^\)]+\))/m';
$str = 'abc | efg || $something("arg|| 1", "arg 2||(a|b)") || 123';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;