// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)style="[a-zA-Z0-9:;\.\s\(\)\-\,]*""#).unwrap();
let string = "<tr class=\"headers\">
<th data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_1_header\" scope=\"col\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:HeadersToolbar.java:93\"><span id=\"label53\" data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_1_header_label\" wicketsource=\"nl.topicuscare.zcd.web.berichten:BerichtenOverzichtPanel.java:138\">
<input name=\"resultaatcontainer:content:berichten:topToolbars:toolbars:2:headers:1:header:label:checkbox\" type=\"checkbox\" id=\"checkbox31\" data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_1_header_label_checkbox\" wicketsource=\"nl.topicuscare.zcd.web.dossier.contentpanel.zoeken:CheckboxPanel.java:126\" class=\"radioboxed\"><label class=\"label--radiobox label--checkbox\" data-selenium-id=\"checkboxSpan\" for=\"checkbox31\"><svg xmlns=\"http://www.w3.org/2000/svg\" viewBox=\"415 285 16 16\" class=\"svg-checkbox\"><path class=\"svg-checkbox__bg\" fill=\"#fff\" d=\"M429,299c0,1.1-0.9,2-2,2h-10c-1.1,0-2-0.9-2-2v-10c0-1.1,0.9-2,2-2h10c1.1,0,2,0.9,2,2V299z\"></path><path class=\"svg-checkbox__stroke\" fill=\"#A0A0A0\" d=\"M427,288c0.6,0,1,0.4,1,1v10c0,0.6-0.4,1-1,1h-10c-0.6,0-1-0.4-1-1v-10c0-0.6,0.4-1,1-1H427 M427,287h-10 c-1.1,0-2,0.9-2,2v10c0,1.1,0.9,2,2,2h10c1.1,0,2-0.9,2-2v-10C429,287.9,428.1,287,427,287L427,287z\"></path><path class=\"svg-checkbox__check--stroke\" stroke=\"#fff\" stroke-width=\"5\" fill=\"none\" d=\"M422,297 430,289\"></path><path class=\"svg-checkbox__check\" stroke=\"#1A8B9D\" stroke-width=\"3\" fill=\"none\" d=\"M418,293 422,297 430,289\"></path><rect class=\"svg-checkbox__intermediate\" x=\"418\" y=\"293\" fill=\"none\" width=\"8\" height=\"3\"></rect></svg></label>
</span></th>
<th data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_2_header\" class=\"wicket_orderNone prioriteitHeader\" scope=\"col\" wicketsource=\"nl.topicus.overheid.orca.wicket.search.markup.html.repeater.data.table:AjaxFallbackHeadersToolbar.java:25\"><a href=\"./?3-1.-contentContainer-content-form-resultaatcontainer-content-berichten-topToolbars-toolbars-2-headers-2-header-orderByLink\" id=\"orderByLink32\" data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_2_header_orderByLink\" wicketsource=\"org.apache.wicket.extensions.ajax.markup.html.repeater.data.sort:AjaxFallbackOrderByBorder.java:58\"><span data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_2_header_orderByLink_header__body_label\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:AbstractColumn.java:78\"></span></a></th>
<th data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_3_header\" class=\"wicket_orderNone bijlageHeader\" scope=\"col\" wicketsource=\"nl.topicus.overheid.orca.wicket.search.markup.html.repeater.data.table:AjaxFallbackHeadersToolbar.java:25\"><a href=\"./?3-1.-contentContainer-content-form-resultaatcontainer-content-berichten-topToolbars-toolbars-2-headers-3-header-orderByLink\" id=\"orderByLink33\" data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_3_header_orderByLink\" wicketsource=\"org.apache.wicket.extensions.ajax.markup.html.repeater.data.sort:AjaxFallbackOrderByBorder.java:58\"><span data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_3_header_orderByLink_header__body_label\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:AbstractColumn.java:78\"></span></a></th>
<th data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_4_header\" class=\"wicket_orderNone\" scope=\"col\" wicketsource=\"nl.topicus.overheid.orca.wicket.search.markup.html.repeater.data.table:AjaxFallbackHeadersToolbar.java:25\"><a href=\"./?3-1.-contentContainer-content-form-resultaatcontainer-content-berichten-topToolbars-toolbars-2-headers-4-header-orderByLink\" id=\"orderByLink34\" data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_4_header_orderByLink\" wicketsource=\"org.apache.wicket.extensions.ajax.markup.html.repeater.data.sort:AjaxFallbackOrderByBorder.java:58\"><span data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_4_header_orderByLink_header__body_label\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:AbstractColumn.java:78\">Type</span></a></th>
<th data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_5_header\" class=\"wicket_orderNone\" scope=\"col\" wicketsource=\"nl.topicus.overheid.orca.wicket.search.markup.html.repeater.data.table:AjaxFallbackHeadersToolbar.java:25\"><a href=\"./?3-1.-contentContainer-content-form-resultaatcontainer-content-berichten-topToolbars-toolbars-2-headers-5-header-orderByLink\" id=\"orderByLink35\" data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_5_header_orderByLink\" wicketsource=\"org.apache.wicket.extensions.ajax.markup.html.repeater.data.sort:AjaxFallbackOrderByBorder.java:58\"><span data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_5_header_orderByLink_header__body_label\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:AbstractColumn.java:78\">Afzender</span></a></th>
<th data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_6_header\" scope=\"col\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:HeadersToolbar.java:93\"><span data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_6_header_label\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:AbstractColumn.java:78\">Betreft</span></th>
<th data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_7_header\" class=\"wicket_orderNone\" scope=\"col\" wicketsource=\"nl.topicus.overheid.orca.wicket.search.markup.html.repeater.data.table:AjaxFallbackHeadersToolbar.java:25\"><a href=\"./?3-1.-contentContainer-content-form-resultaatcontainer-content-berichten-topToolbars-toolbars-2-headers-7-header-orderByLink\" id=\"orderByLink36\" data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_7_header_orderByLink\" wicketsource=\"org.apache.wicket.extensions.ajax.markup.html.repeater.data.sort:AjaxFallbackOrderByBorder.java:58\"><span data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_7_header_orderByLink_header__body_label\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:AbstractColumn.java:78\">Onderwerp</span></a></th>
<th data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_8_header\" class=\"wicket_orderNone\" scope=\"col\" wicketsource=\"nl.topicus.overheid.orca.wicket.search.markup.html.repeater.data.table:AjaxFallbackHeadersToolbar.java:25\"><a href=\"./?3-1.-contentContainer-content-form-resultaatcontainer-content-berichten-topToolbars-toolbars-2-headers-8-header-orderByLink\" id=\"orderByLink37\" data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_8_header_orderByLink\" wicketsource=\"org.apache.wicket.extensions.ajax.markup.html.repeater.data.sort:AjaxFallbackOrderByBorder.java:58\"><span data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_8_header_orderByLink_header__body_label\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:AbstractColumn.java:78\">Ontvangen</span></a></th>
<th data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_9_header\" scope=\"col\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:HeadersToolbar.java:93\"><span data-wicket-path=\"contentContainer_content_form_resultaatcontainer_content_berichten_topToolbars_toolbars_2_headers_9_header_label\" wicketsource=\"org.apache.wicket.extensions.markup.html.repeater.data.table:AbstractColumn.java:78\"></span></th>
</tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}