$re = '/^([\d\w]{3})(\|[\d\w]{3})*$/m';
$str = 'dcc|dfg|456
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);