re = /^(?:[a-z0-9\-]{1,63})?\.smartmember\.(?:com|in|dev|soy|pro|co)$/i
str = '4fjd.smartmember.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end