$re = '/(?<=(.))(?=((\w*)(\w*(?!\1)\w\3)\4+))/';
$str = '#atattatt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);