re = /^(?![^a-z]*$|[^A-Z]*$|[^0-9]*$|[^!#$%^&*]*$|.*?job corps)[^@]*$/m
str = 'lapin6A& job corp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end