#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?\K\d+\.\d+\.\d+"
Local $sString = "Nå skal folk få fred, iTromsø, 09.09.2017 19:09 Martin Lægland, Publisert på nett." & @CRLF & _
"Nå skal folk få fred, iTromsø, 09.09.2017, Martin Lægland 31.12.2017 Publisert på nett." & @CRLF & _
"Nå skal folk få fred, iTromsø, 09.09.2017 19:09 Martin Lægland, Publisert på nett."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")