import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(1?[0-9]{1,2}|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\\b";
final String string = "000000000000000\n"
+ "00\n"
+ "01\n"
+ "99\n"
+ "255\n"
+ "256\n"
+ "100\n"
+ "150\n"
+ "175\n"
+ "200\n"
+ "250\n"
+ "0\n"
+ "001\n"
+ "011\n"
+ "013\n"
+ "014\n"
+ "001\n"
+ "256";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}