use strict;
my $str = 'Match any nine digit number surrounded by word boundaries, but not those preceded by a period.
123456789 Should match
123456789 Should match
123456789. Should match
0.123456789 Should not match
.123456789 Should not match';
my $regex = qr`\b\d{9}\b`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}