$re = '/[^,.:0\/]+/m';
$str = '28:30
28
100:30
100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);