$re = '/^(2[5-9]\d*|[3-9]\d+|[12]\d{2,})000$/m';
$str = '25000
25000100
234000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);