package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{8}`)
var str = `some words 1234567890 0987654321`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}