$re = '/\d{8}\b(?![\s\S]*\d{8}[\s\S]*$)/';
$str = 'some words 1234567890 0987654321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);