re = /\d{8}\b(?![\s\S]*\d{8}\b[\s\S]*$)/
str = 'some words 1234567890 0987654321'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end