#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "FILTER(?:\n(?!ORDER)(.*))?\nORDER(?:\n(?!FILTER)(.*))?"
Local $sString = "FILTER" & @CRLF & _
"test1" & @CRLF & _
"ORDER" & @CRLF & _
"test2" & @CRLF & _
"FILTER" & @CRLF & _
"test3" & @CRLF & _
"ORDER" & @CRLF & _
"FILTER" & @CRLF & _
"ORDER"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")