import re
regex = re.compile(r"((([0-9a-fxA-FX]){2})(?|[,\n])){8,16}", flags=re.MULTILINE)
test_str = ("Windows Registry Editor Version 5.00\n"
"[HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\MultiKey\\Dumps\\D9DA0000]\n"
"\"DongleType\"=dword:00000003\n"
"\"Copyright\"=\"None\"\n"
"\"Created\"=\"Tue Jan 08 10:33:00.496 2013\" by dmp2mkey\n"
"\"Name\"=\"D9DA Sentinel SuperPro Dump\"\n"
"\"Type\"=dword:00000000\n"
"\"CellType\"=hex:\\ \n"
" 01,01,03,03,03,01,03,01,\\ \n"
" 03,03,00,00,00,00,00,00,\\ \n"
" 00,00,00,00,01,00,00,01,\\ \n"
" 00,00,01,00,00,01,00,00,\\ \n"
" 00,00,00,00,00,00,00,00,\\ \n"
" 00,01,00,00,00,00,00,00,\\ \n"
" 00,00,01,00,00,00,00,00,\\ \n"
" 00,00,00,00,00,00,00,00\n"
"\"sntMemory\"=hex:\\ \n"
" 01,1A,DA,D9,00,00,00,00,EF,5D,01,00,DE,59,11,00,\\ \n"
" 31,FA,A0,F0,00,00,00,00,F0,55,00,00,F0,55,00,00,\\ \n"
" F0,55,00,00,F0,55,47,00,01,00,FF,00,01,00,FF,00,\\\n"
" 01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\\n"
" 01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\\n"
" 01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\\n"
" 01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\\n"
" 01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")