$re = '/^[$A-Z_][0-9A-Z_$]*$/i';
$str = 'mul
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);