import Foundation
let pattern = #"^[0-9]{1,3}.[0-9]{1,3}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
103.145.72.0/24 Alibaba.com HK(Kaopuyun) 256
110.76.21.0/24 Zhejiang Ant Small And Micro Financial Services 256
122.254.76.0/23 Internet Global (group) Co., LTD 512
116.251.120.0/22 Zhejiang Taobao Network Co.,Ltd 1,024
149.129.16.0/23 Alibaba.com Singapore E-Commerce Private Limited 512
8.209.96.0/19 Westendstrabe 28, 60325 Frankfurt am Main 8,192
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)