package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)en.?$`)
var str = `forgotten
attend
but not:
attained`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}