package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:[\d\sx]+)?(?:\[.*\]\s)?(?:(.*)(?:[\(\/].*)$|(.*)(?:foil)|(.*?)\d|(.*))`)
var str = `4x Silhana Ledgewalker (Silhana Saltador de Peitoril) - NM
4x Kiln Fiend (Demônio Fornalha) - NM
4x Assault Strobe (Estroboscópio de Ataque) - NM
1x [Expedition] Wasteland
Urborg, Tomb of Yawgmoth
4 Thoughtcast
1x [OGW] Kozilek, a Grande Distorção
1x [OGW] Retorno de Kozilek
1x [OGW] Retorno de Kozilek
1x [OGW] Linvala, a Preservadora
Regal Force
2 Bloodstained Mire
4 Relic of Progenitus
1x Olho de Ugin / Eye of Ugin FOIL
1x Templo dos Eldrazi / Eldrazi Temple
1x [Expedition] Prairie Stream (Mint)
2x World Breaker / Rompe-mundos Mint
4x Holy Day (Dia Sagrado) - NM
1x TAmpo de adivinhação do sensei
1 x Gosmanuladora
1 x Gaddock Teeg
4x Força de Vontade
1x Fractius Pele Preciosa / Gemhide Sliver
1x Lupíneo Coração de Prata / Wolfir Silverheart
1 x Inquisição de Kozilek 4 de 4
1 x Gosmanuladora
Tropical island
1x Ugin's Nexus foil
1x Visões do Soro FOIL \"FNM\"
1x Labirinto Nimboso / Nimbus Maze
1x Espadas em Arados / Swords to Plowshares
1x Regiões Agrestes de Adarkar / Adarkar Wastes
1x Costa do Mar de Cromo / Seachrome Coast
1x Presente do Molda-aço / Steelshaper\\\\
1x Aprisionar / Remand
1x Imposto Territorial / Land Tax
1x Pasmar / Daze (JP)
1x Magiaprisionar / Trickbind
2x Comandante do Elmo de Coral / Coralhelm Commander
1x Caminho para o Exílio / Path to Exile
2x Thrun, the Last Troll/ Thrun, o Último Troll **NM**
1x Cone de Vapor / Vapor Snag
1x Cone de Vapor / Vapor Snag
1x Cone de Vapor / Vapor Snag
1x Cone de Vapor / Vapor Snag
1x Cone de Vapor / Vapor Snag`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}