$re = '/[a-z][0-9]+\.[0-9]+/';
$str = 'a12.32';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);