import Foundation
let pattern = #"^.*\/(.*?.xls)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://vcu.edu.vn/vi/adminaspx/filesupload/DANH%20SACH%20DANG%20KY_12.xls"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
    let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
    print(result)
} else {
    print("No matches were found.")
}