const regex = /(@|\*)(?<tag>[A-Z]{1}[a-z]{2,})\1: (?<message>\[[A-Z]\]\|(\[[A-z]\]\|){1}(\[[a-z]\]\|))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(@|\\*)(?<tag>[A-Z]{1}[a-z]{2,})\\1: (?<message>\\[[A-Z]\\]\\|(\\[[A-z]\\]\\|){1}(\\[[a-z]\\]\\|))', 'g')
const str = ` '3',
'@Taggy@: [i]|[n]|[v]|[a]|[l]|[i]|[d]| this shouldnt be valid',
'*tAGged*: [i][i][i]|',
'Should be invalid @Taggy@: [v]|[a]|[l]|[l]|[l]|'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}