$re = '/(?<foobar>foo|bar)#(?&foobar)%(?&foobar)/';
$str = 'bar#foo%bar';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);