re = /(.*?(?:;|$))(?![^"]*")/m
str = 'TZID="Greenwich Mean Time:Dublin; Edinburgh; Lisbon; London";VALUE=DATE;RSVP=FALSE;LANGUAGE=en-gb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end