import re
regex = re.compile(r"\s*(\d+).*changed,\s+(\d*)(?P<in>\s+insertion).*(\d+)(?P<del>\s+deletion).*", flags=re.MULTILINE)
test_str = ("1 file changed, 1 insertion(+), 1 deletion(-)\n"
"2 files changed, 10 insertions(+), 10 deletions(-)\n"
"1 file changed, 1 insertion(+)\n"
"1 file changed, 2 deletions(-)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")