re = /\[?(?<groupA>[A])?(?:[ ]*)?(?<groupB>[B])?(?:[ ]*)?(?<groupC>[C])\]/m
str = '[A B C]
[A C]
[B C]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end