package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\*\*([^\*]*)\*\*`)
var str = `ads **is** a **test**
that's **right * a test**`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}