import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)\\b[A-Z][A-Z '-]*(?= |$)";
final String string = "wikiradio 27/09/2012 - LE QUATTRO GIORNATE DI NAPOLI raccontate da Ida Gribaudi\n\n"
+ "wikiradio 10/04/2013 - DAG HAMMARSKJOLD\n\n"
+ "wikiradio 11/02/2014 - L'ABBE' PIERRE raccontato da Giovanni Anversa\n\n"
+ "wikiradio 22/12/2015 - JEAN-MICHEL BASQUIAT";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}