$re = '/[^_]+$/m';
$str = '5_100_abc
5_123_abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);