use strict;
my $str = 'INSERT INTO fa_MISC_JUL16 (F_ID, X2, X3, X4, X6, G3, E9, D9, V9, P01, T4, R2, CX050, NX01, M11) VALUES (17051, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1)
INSERT INTO fa_data1_JUL16 (F_ID, F_FULL_NAME, F_ADDRESS, F_AWARD, F_DEADLINE_DATE, F_DURATION, F_OTHER_SPONSORS, F_PURPOSE, F_SPONSOR, F_MX_sponsor, F_PX_sponsor, F_WEBSITE, F_ELIGIBILITY, F_SPECIAL_FEATURES) VALUES (38286, \'A. Bartlett Giamatti Fellowship\', \'Attn: Beinecke Rare Book and Manuscript Library<br>120 High Street<br>P.O. Box 208330<br>New Haven, CT 06520-8330\', \'The program supports travel to and from New Haven and pays a living allowance of $4,000 per month for postdoctoral fellows or $3,000 per month for doctoral candidates.\', \'December of each year for postdoctoral fellows or October of each year for doctoral candidates.\', \'1 to 3 months between October and May for postdoctoral fellows or between June and August for doctoral candidates.\', \'Yale University. Beinecke Rare Book and Manuscript Library\', \'To provide short-term funding to postdoctoral scholars and doctoral candidates from any country interested in conducting research in history or literature using the resources of the Beinecke Rare Book and Manuscript Library at Yale University.\', \'Yale University\', \'\', \'\', \'beinecke.library.yale.edu/programs-events/fellowship-program\', \'This program is open to visiting scholars from any country interested in conducting postdoctoral or dissertation research in history or literature at the Beinecke Library. Applicants should live outside the greater New Haven area. Along with their application, they must submit a curriculum vitae, 2 letters of recommendation,
a 1,200-word research proposal, and a detailed list of specific research materials to be consulted at the Beinecke.\', \'Recipients are expected to be in residence during the period of their award and are encouraged to participate in the activities of Yale University.\')
';
my $regex = qr/[^\$]\s1([,|)])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}