re = /^((https?):\/\/)?([wW]{3}\.)?[a-zA-Z0-9\-.]{3,}\.[a-zA-Z]{2,}(\.[a-zA-Z]{2,})?$/m
str = 'This is currently working for:
http://www.google.com
www.google.com
but not for
google.com
http://google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end