$re = '/(?<!\w)a\w*/i';
$str = 'Apple is super delicious. An ant is as good as my cat which favors a pear than fish. I\'m going to test them all at once.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);