package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?<first>.*?)(?<last>[\d.]+)\)`)
var str = `cos(3 * 3) + cos(3 * 24.5), cos(2 * 3) + cos(3 * 2.4)
cos(3 * 3.4) + cos(3 * 45), cos(4 * 2) + cos(3 * 245)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}