$re = '/^(?!.*\.tar\.gz$).*\.gz$/m';
$str = 'file1.gz
file.1.gz
file2.tar.gz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);