re = /<div\sclass="row">\s<div\sclass="col-xs-12">\s<div\sclass="all_seasons">\s<div\sclass="episodes_left\scol-xs-6\spull-left">\s((.|\n)*)<br>(?:(<\/div>|\s)*?)/x
str = '<div class="row">
<div class="col-xs-12">
<div class="all_seasons">
<div class="episodes_left col-xs-6 pull-left">
<a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e32\'>Last Week Tonight With John Oliver S02E32 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e31\'>Last Week Tonight With John Oliver S02E31 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e30\'>Last Week Tonight With John Oliver S02E30 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e29\'>Last Week Tonight With John Oliver S02E29 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e28\'>Last Week Tonight With John Oliver S02E28 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e27\'>Last Week Tonight With John Oliver S02E27 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e25-church\'>Last Week Tonight With John Oliver S02E25 – Church </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e24-season-2-episode-24\'>Last Week Tonight With John Oliver S02E24 – Season 2, Episode 24 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e23-season-2-episode-23\'>Last Week Tonight With John Oliver S02E23 – Season 2, Episode 23 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e23-season-2-episode-23-720p\'>Last Week Tonight With John Oliver S02E23 – Season 2, Episode 23 720p </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e22-season-2-episode-22-720p\'>Last Week Tonight With John Oliver S02E22 – Season 2, Episode 22 720p </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e22-season-2-episode-22\'>Last Week Tonight With John Oliver S02E22 – Season 2, Episode 22 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e21-season-2-episode-21\'>Last Week Tonight With John Oliver S02E21 – Season 2, Episode 21 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e21-season-2-episode-21-720p\'>Last Week Tonight With John Oliver S02E21 – Season 2, Episode 21 720p </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e20-season-2-episode-20\'>Last Week Tonight With John Oliver S02E20 – Season 2, Episode 20 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e20-season-2-episode-20-720p\'>Last Week Tonight With John Oliver S02E20 – Season 2, Episode 20 720p </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e19-season-2-episode-19-720p\'>Last Week Tonight With John Oliver S02E19 – Season 2, Episode 19 720p </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e19-season-2-episode-19\'>Last Week Tonight With John Oliver S02E19 – Season 2, Episode 19 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e18-season-2-episode-18-720p\'>Last Week Tonight With John Oliver S02E18 – Season 2, Episode 18 720p </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e18-season-2-episode-18\'>Last Week Tonight With John Oliver S02E18 – Season 2, Episode 18 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e17-season-2-episode-17\'>Last Week Tonight With John Oliver S02E17 – Season 2, Episode 17 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e17-season-2-episode-17-720p\'>Last Week Tonight With John Oliver S02E17 – Season 2, Episode 17 720p </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e16-season-2-episode-16\'>Last Week Tonight With John Oliver S02E16 – Season 2, Episode 16 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e16-season-2-episode-16-720p\'>Last Week Tonight With John Oliver S02E16 – Season 2, Episode 16 720p </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e15-season-2-episode-15\'>Last Week Tonight With John Oliver S02E15 – Season 2, Episode 15 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e15-season-2-episode-15-720p\'>Last Week Tonight With John Oliver S02E15 – Season 2, Episode 15 720p </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e14-season-2-episode-14\'>Last Week Tonight With John Oliver S02E14 – Season 2, Episode 14 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e13-season-2-episode-13\'>Last Week Tonight With John Oliver S02E13 – Season 2, Episode 13 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e13-season-2-episode-13-720p\'>Last Week Tonight With John Oliver S02E13 – Season 2, Episode 13 720p </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e12-season-2-episode-12\'>Last Week Tonight With John Oliver S02E12 – Season 2, Episode 12 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e11-season-2-episode-11\'>Last Week Tonight With John Oliver S02E11 – Season 2, Episode 11 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e10-season-2-episode-10\'>Last Week Tonight With John Oliver S02E10 – Season 2, Episode 10 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e09-season-2-episode-9\'>Last Week Tonight With John Oliver S02E09 – Season 2, Episode 9 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e08-season-2-episode-8\'>Last Week Tonight With John Oliver S02E08 – Season 2, Episode 8 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e07-season-2-episode-7\'>Last Week Tonight With John Oliver S02E07 – Season 2, Episode 7 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e05-season-2-episode-5\'>Last Week Tonight With John Oliver S02E05 – Season 2, Episode 5 </a>
<br></div><div class=\'col-xs-6 pull-right\'> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e04-season-2-episode-4\'>Last Week Tonight With John Oliver S02E04 – Season 2, Episode 4 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-with-john-oliver-s02e03-season-2-episode-3\'>Last Week Tonight With John Oliver S02E03 – Season 2, Episode 3 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-john-oliver-s02e02-season-2-episode-2\'>Last Week Tonight With John Oliver S02E02 – Season 2, Episode 2 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-john-oliver-s02e01-season-2-episode-1\'>Last Week Tonight With John Oliver S02E01 – Season 2, Episode 1 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-john-oliver-s01e24\'>Last Week Tonight With John Oliver S01E24 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-john-oliver-s01e23\'>Last Week Tonight With John Oliver S01E23 </a>
<br> <a href=\'http://watchseries-online.li/episode/last-week-tonight-john-oliver-s01e22\'>Last Week Tonight With John Oliver S01E22 </a>
<br> <a href=\'http://watchseries-online.li/2014/10/last-week-tonight-with-john-oliver-s01e21\'>Last Week Tonight With John Oliver S01E21 </a>
<br> <a href=\'http://watchseries-online.li/2014/10/last-week-tonight-with-john-oliver-s01e20\'>Last Week Tonight With John Oliver S01E20 </a>
<br> <a href=\'http://watchseries-online.li/2014/09/last-week-tonight-with-john-oliver-s01e19\'>Last Week Tonight With John Oliver S01E19 </a>
<br> <a href=\'http://watchseries-online.li/2014/09/last-week-tonight-with-john-oliver-s01e18\'>Last Week Tonight With John Oliver S01E18 </a>
<br> <a href=\'http://watchseries-online.li/2014/09/last-week-tonight-with-john-oliver-s01e17\'>Last Week Tonight With John Oliver S01E17 </a>
<br> <a href=\'http://watchseries-online.li/2014/09/last-week-tonight-with-john-oliver-s01e16\'>Last Week Tonight With John Oliver S01E16 </a>
<br> <a href=\'http://watchseries-online.li/2014/08/last-week-tonight-with-john-oliver-s01e15\'>Last Week Tonight With John Oliver S01E15 </a>
<br> <a href=\'http://watchseries-online.li/2014/08/last-week-tonight-with-john-oliver-2014-08-10\'>Last Week Tonight With John Oliver (2014 08 10) </a>
<br> <a href=\'http://watchseries-online.li/2014/08/last-week-tonight-with-john-oliver-s01e13\'>Last Week Tonight With John Oliver S01E13 </a>
<br> <a href=\'http://watchseries-online.li/2014/07/last-week-tonight-with-john-oliver-2014-07-27\'>Last Week Tonight With John Oliver (2014 07 27) </a>
<br> <a href=\'http://watchseries-online.li/2014/07/last-week-tonight-with-john-oliver-2014-07-27-readnfo\'>Last Week Tonight With John Oliver (2014 07 27) Readnfo </a>
<br> <a href=\'http://watchseries-online.li/2014/07/last-week-tonight-with-john-oliver-s01e11\'>Last Week Tonight With John Oliver S01E11 </a>
<br> <a href=\'http://watchseries-online.li/2014/07/last-week-tonight-with-john-oliver-s01e10\'>Last Week Tonight With John Oliver S01E10 </a>
<br> <a href=\'http://watchseries-online.li/2014/06/last-week-tonight-with-john-oliver-s01e09\'>Last Week Tonight With John Oliver S01E09 </a>
<br> <a href=\'http://watchseries-online.li/2014/06/last-week-tonight-with-john-oliver-s01e08\'>Last Week Tonight With John Oliver S01E08 </a>
<br> <a href=\'http://watchseries-online.li/2014/06/last-week-tonight-with-john-oliver-s01e07\'>Last Week Tonight With John Oliver S01E07 </a>
<br> <a href=\'http://watchseries-online.li/2014/06/last-week-tonight-with-john-oliver-s01e06-real-wso-ch\'>Last Week Tonight With John Oliver S01E06 Real wso-ch </a>
<br> <a href=\'http://watchseries-online.li/2014/06/last-week-tonight-with-john-oliver-s01e06\'>Last Week Tonight With John Oliver S01E06 </a>
<br> <a href=\'http://watchseries-online.li/2014/05/last-week-tonight-with-john-oliver-2014-05-18-repack\'>Last Week Tonight With John Oliver (2014 05 18) Repack </a>
<br> <a href=\'http://watchseries-online.li/2014/05/last-week-tonight-with-john-oliver-2014-05-18\'>Last Week Tonight With John Oliver (2014 05 18) </a>
<br> <a href=\'http://watchseries-online.li/2014/05/last-week-tonight-with-john-oliver-2014-05-11-2\'>Last Week Tonight With John Oliver (2014 05 11) </a>
<br> <a href=\'http://watchseries-online.li/2014/05/last-week-tonight-with-john-oliver-2014-05-11\'>Last Week Tonight With John Oliver (2014 05 11) </a>
<br> <a href=\'http://watchseries-online.li/2014/05/last-week-tonight-with-john-oliver-s01e02\'>Last Week Tonight With John Oliver S01E02 </a>
<br> <a href=\'http://watchseries-online.li/2014/04/last-week-tonight-with-john-oliver-s01e01\'>Last Week Tonight With John Oliver S01E01 </a>
<br> </div>
</div>
</div>
</div>
</div>
</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end