$re = '/^[0-9+]{14}$/';
$str = '+9779843224697
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);