# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?xsm) # free-spacing mode, DOTALL, multi-line\n"
r"(?=.*?blue) # if blue isn't there, fail without delay\n\n"
r"########### LINE SKIPPER / COUNTER ############\n"
r"(?: # start non-capture group\n"
r" # the aim is to skip lines that don't contain blue\n"
r" # and capture a corresponding digit sequence\n"
r" (?: # skip one line that doesn't contain blue\n"
r" ^ # beginning of line\n"
r" (?:(?!blue)[^\r\n])* # zero or more chars\n"
r" # that do not start blue\n"
r" (?:\r?\n) # newline chars\n"
r" ) \n"
r"# With each line skipped, let Group 1 capture\n"
r"# an ever-increasing portion of the string of numbers\n"
r" (?= # lookahead\n"
r" [^~]+ # skip all chars that are not tildes\n"
r" ( # start Group 1\n"
r" (?(1)\1) # if Group 1 is set, match Group 1\n"
r" # (?>\1?) # alternate phrasing for the above\n"
r" ~\d+ # match a tilde and digits\n"
r" ) # end Group 1\n"
r" ) # end lookahead\n"
r")*+ # end counter-line-skipper: zero or more times\n"
r" # the possessive + forbids backtracking\n\n\n"
r".*? # lazily match any chars up to...\n"
r"blue # match blue\n"
r"[^~]+ # match any non-tilde chars\n"
r"(?(1)\1) # if Group 1 has been set, match it\n"
r"# \1? # alternate phrasing for the above\n"
r"~ # match a tilde\n"
r"\K # drop what we matched so far\n"
r"\d+ # match digits. This is the match! ")
test_str = ("Paint it white\n"
"Paint it black\n"
"Why not blue?\n"
"Or red or brown?\n\n"
"~1~2~3~4~5~6~7~8~9~10")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.