$re = '/\{(?!(?:token1|token2)\}).*?\}/';
$str = 'qwert yuiop
qwert{token1}yuiop
qwert{token1}{token2}yuiop
qwert {token1} {token2} yuiop
qwert {badtoken} yuiop
qwert { badtoken} yuiop
qwert {badtoken } yuiop
qwert { token1} yuiop
qwert {token1 } yuiop
qwert { token1 } yuiop
qwert {badtoken} {token1} yuiop
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);